MyCarHelpline Forum for Premium Support !!

Get Professional Support from Experts. Ask your Question Now !!

  1. Danny
  2. Service & Maintenance
  3. Sunday, November 24 2019
My Wagon R (2015) have tuk tuk sound somewhere under the body, and after driving for about 14 min or more the sound become less. Some says comes from the steering box, but when I turn the steering it does not give any sound. Some says it might be problem with the engine mounting. The Maruti Service people does not seem to know exactly the problem. Kindly advise.
Admin Accepted Answer
0
Votes
Undo
Hello,

> The sound coming from front or Rear ?
> Is it only after initial driving ?
> Is Sound increases when driven on bad patch roads

There can be one to multiple reason
> Something gone bad in suspension - Lower Arm, Bushes, Shockers, Link Road, Engine Mount causing in noise
> Steering Rack
> Misaligned Belt or loosen tension in under bonnet

It needs a close inspection from authorized professional workshop
If Maruti Workshop unable to resolve, make a compliant to service team of OEM


  1. more than a month ago
  2. Service & Maintenance
  3. # 1
Danny Accepted Answer
0
Votes
Undo
The noise is coming from the front and underbody. Thats why during my last year's visit to maruti workshop I was told it is due to steering box. But when I visit again last month I was told it was just some clippers or something small an it was changed. But the problem lingers. The tuk2 sound lessens after about 10-20KM drive


  1. more than a month ago
  2. Service & Maintenance
  3. # 2
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar
• Remove Upload Files (Maximum File Size: 1 MB)
You may insert polls into your post. The poll would then appear in the post.
Vote Options
Captcha
Verify