Car Forum - Ask & Answer Questions Online

Welcome to Mycarhelpline.com Automotive Forum !!

  1. KAPIL
  2. Service & Maintenance
  3. Friday, July 12 2019
I have a MS Baleno Zeta variant 1.2(P) which I bought in December 2018 (October Manufactured).I have driven about 1900 Kms till date.I also have completed two free services.From the time I bought this vehicle,I been hearing this "swish" sounds when applying brakes even at slow speeds.

These sounds come primarily come from the front while applying brakes.I brought this issue up with the Dealer workshop many a times but they say it's normal.I want to get a genuine answer to know if it is normal or is it something really wrong with it?
Admin Accepted Answer
0
Votes
Undo
Hello,

Yes - something is not correct here and more concerning is that dealer workshop not able to resolve
There should not be any sound while applying brakes which should be visible in cabin

Suggest to ask them to check for
> Clean Brake Pads (although its a 6 month old car and brake pads do not wear so fast but still may ask them check leather thickness on pads)
> Check and Inspect Brake Rotor disc
> Check Caliper Pin and if require greasing should be done

Ideally by doing brake cleaning and caliper pin greasing issue should be resolved
Hope should help !!


  1. more than a month ago
  2. Service & Maintenance
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar
• Remove Upload Files (Maximum File Size: 1 MB)
You may insert polls into your post. The poll would then appear in the post.
Vote Options
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.