Car Forum - Ask & Answer Questions Online

Welcome to Mycarhelpline.com Automotive Forum !!

  1. Laljo
  2. Service & Maintenance
  3. Friday, July 06 2018
I owned a Tata Nano 2012 model, I've been using the car for the past 5 years now. Recently, I have a problem when running after a few meters, my car check engine light and overheat lights comes on. And the acceleration of the car is far away from normal, there was throbbing sound from the engine and couldn't go on much longer. The car was shaken abit from the engine movement too. I thought it might me overheating problem, so I refill the coolants, clean the radiators etc and then the problem was resolved for the day.

The same problem arises the next day. Went to a local mechanic and had him searched for the problem. He couldn't find any solution.

I took a short video of it, if you can view it, please give me suggestions as to how to fix my problem. Thanks.

Link of the video -
Admin Accepted Answer
0
Votes
Undo
Hello,

Its good that the coolant was topped in and radiator fan was also checked
As you referred that the issue was resolved after topping up coolant and cleaning radiator fan

> But was there any leakage of coolant, did you checked engine oil - is there leak going and mixed with oil and how is oil level
> Whats the coolant level now, was the water pump also checked
> Were the Belts been checked and tensioned properly by the mechanic

I think you need to refer to a professional Tata Motor workshop to assess the car
Hope should help !!


  1. more than a month ago
  2. Service & Maintenance
  3. # 1
Sachin Accepted Answer
0
Votes
Undo
Same problem of my car suggest me ....
  1. more than a month ago
  2. Service & Maintenance
  3. # 2
Amar gautam Accepted Answer
0
Votes
Undo
Hey buddy did you find any solutions for this... Same problem over here
  1. more than a month ago
  2. Service & Maintenance
  3. # 3
Shahid Accepted Answer
0
Votes
Undo
It's the knock sensor error when the car heats and the engine starts to jerk and after a while the car turns off automatically (check engine light and heat light blink together)
  1. more than a month ago
  2. Service & Maintenance
  3. # 4
C Bhargava Sarma Accepted Answer
0
Votes
Undo
I am having the same problem my mechanic changed Water pump and timing tension er he gave car today after repair. I went to a distance of 16 Kms in the morning at 8 am and reached destination at 8.50 there was no treble. I thought my car problem solved. but in the return journey started at 10. a.m. the sun is hot I could run car for about 5 Kms. but the car engine is giving some sticky sound. I though the problem is repeated. the red indicator of engine heating blinked with sound I stopped the car at road side and after 15 minutes I started the car and went about 1 Km hardly. there the car again stopped. I could not start the car inspite of turning key several times. after 3 hrs. with great Difficulty engine started. now the yellow MLC indicator is glowing and the car is running heavily the pickup is very less. the engine is giving jerks. at last i reached the shed of my mechanic. he went a trial ride. he told there is not problem. again i took the car and came to my house. at that time the car run as usual. what the problem of my car. I am unable to understand. plz. anybody got the similar problem solved suggest me. . .


  1. more than a month ago
  2. Service & Maintenance
  3. # 5
Yogi Accepted Answer
0
Votes
Undo
This issue may be solved by cleaning the fuel tank and checking the radiator fan. If radiator fan is not working properly (means sometimes it runs and sometime it doesn't) then check with your ECU.
  1. more than a month ago
  2. Service & Maintenance
  3. # 6
Subramaniam Accepted Answer
0
Votes
Undo
The same issue occurs here also. I checked with my Tata Workshop. They said some pressure cap might be the issue. For past 2 days I am seeing this problem. Please suggest if you guys find any solution
  1. more than a month ago
  2. Service & Maintenance
  3. # 7
Sandeep Accepted Answer
0
Votes
Undo
Same problem is in my zest car
Heating and check engine light blinks together with a beep sound, then car doesn't take accelerat and ac stops working
After exit the key then start, car moving normal but ac didn't work, it start after 15 min to 45 min.
Problem comes continue,
  1. more than a month ago
  2. Service & Maintenance
  3. # 8
Vikram Elavarasan Accepted Answer
0
Votes
Undo
Hi All,
I am facing the same problem for the last two years with my Nano 2012 model. I have to frequently change the coolant. I remember changing it 3 times in the last 8 months. Fan is working , no visible leaks of the coolant, but the problem still persists.
What should I do?
  1. more than a month ago
  2. Service & Maintenance
  3. # 9
Nelson Accepted Answer
0
Votes
Undo
I too had same problem with Nano XTA couple of days back. Took it to authorised service centre and they found error in ECU and it needs to be replaced.. waiting for the repairs to be done.
  1. more than a month ago
  2. Service & Maintenance
  3. # 10
POOMANI Accepted Answer
0
Votes
Undo
i have nano 2011 modal i have face same problem last 2 months my car running 25 km normal after engine light blowing vehicle blocking to stop after few hours normal going 25 km get same problem my mechanic was told change the sensor after same problem some body told to solve the problem
  1. more than a month ago
  2. Service & Maintenance
  3. # 11
bhaskar shyam Accepted Answer
0
Votes
Undo
Since from a few days , iam getting the same problem with my tata Nano CX . After driving a few kilometres ,my car dashboard started showing this two signals ( MIL & HEATING) . At first I thought that there may be some problem with the coolent which I filled a few days back . So, I changed the coolent and washed the radiator system but even though the problem remains the same . went to the garage to show this problem . nobody knows how to clear this problem .although, in YouTube video, a person was showing the same problem and later he commented that his problem was solved by releasing the air pressure from the coolent pipe . What do you guys this ? Should we follow this trick ? Please , comment .
  1. more than a month ago
  2. Service & Maintenance
  3. # 12
Tushar Accepted Answer
0
Votes
Undo
I am also facing the same problem. The engine show beep sound (MIL & HEATING) and after checked with TATA service center they cleared the error. Now again the sound comes, issue still persists till occurs after car is driven for more than 1 hr. Water coolant is fine, radiator fan works fine. dont know whats the issue, even tata service centre does not know. please help
  1. more than a month ago
  2. Service & Maintenance
  3. # 13
Lashan Accepted Answer
0
Votes
Undo
Hi, I also have a nano car and I had to face this problem too. Then I replaced the temperature sensor. then it solved.
  1. more than a month ago
  2. Service & Maintenance
  3. # 14
Lashan Accepted Answer
0
Votes
Undo
Hi All,
I am facing the same problem for the last two years with my Nano 2012 model. I have to frequently change the coolant. I remember changing it 3 times in the last 8 months. Fan is working , no visible leaks of the coolant, but the problem still persists.
What should I do?


bro i face the same problem. I think your car radiator tank has a crack. but it not visible.when radiator get heat , water leak from that crack. You can replace the radiator tank or replace a new radiator. Best is replace new one.
  1. more than a month ago
  2. Service & Maintenance
  3. # 15
vtv Accepted Answer
0
Votes
Undo
I was too having this problem but after replacing hose pipes and servicing water pump issue resolved.
  1. more than a month ago
  2. Service & Maintenance
  3. # 16
Sritharan Accepted Answer
0
Votes
Undo
I am facing the same problem. I checked coolant oil level its very low then I have top-up coolant oil with water. Finally my problem is solved.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar
• Remove Upload Files (Maximum File Size: 1 MB)
You may insert polls into your post. The poll would then appear in the post.
Vote Options
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.