MyCarHelpline Forum for Premium Support !!

Get Professional Support from Experts. Ask your Question Now !!
  Thursday, 07 September 2017
  10 Replies
  7.3K Visits
Hi Guys,

I have Beat LT Petrol car. Suddenly the audio display went off today. I'm not sure what button or action caused this. But the audio is working in all modes like cd/aux and Band. Any idea of what caused this and is there any way to turn on the display to normal? Any suggestion is greatly appreciated.

Thanks!
5 years ago
·
#19990
Hello,

Could be a simple fuse issue which is causing the blank display in Music system
The head unit music system has i believe 2 fuses which can be checked after taking the music system out - is generally on the back end side of music system head unit

Suggest to show it to chevy workshop to get it inspected
Would be a simple 10 to 15 minute job
4 years ago
·
#22495
central locking is not working; music system display is gone blank; cd is not going into the slot
3 years ago
·
#27337
Same problem for my swift szire vdi 2010 model
3 years ago
·
#27558
HI

My chevrolet beat lt opt Music system volume lowering automatically to 0, what is the problem??, pls hlp
My Chevrolet aveo car audio player no display also switch is not working but light are showing.
Please suggest me what to do.
Thanks
Regards
Joytosh debbarma
2 years ago
·
#33024
Hello
I have a same question (I have Beat LT Petrol car. Suddenly the audio display went off today. I'm not sure what button or action caused this. But the audio is working in all modes like cd/aux and Band. Any idea of what caused this and is there any way to turn on the display to normal? Any suggestion is greatly appreciate).

And you answer for this problem ( Could be a simple fuse issue which is causing the blank display in Music system
The head unit music system has i believe 2 fuses which can be checked after taking the music system out - is generally on the back end side of music system head unit

Suggest to show it to chevy workshop to get it inspected
Would be a simple 10 to 15 minute job).
I would like to know the location of the fuses. Is it inside the stereo or anywhere ? Please suggest.
2 years ago
·
#33285
Hi Brother, I am facing the same issue, music system of my Beat LT suddenly went blank/black however, music fucntions such as cd , usb , aux etc are working.. please suggest how did you sort out this issue..

Would sincerely wait for your reply in this..

Thanks in advance,
Nitesh
+91-8700753458,
2 years ago
·
#34642
:) SAME PROBLEM IN MY BEAT CAR
PLEASE TELL ME WHERE IS THE PROBLEM
11 months ago
·
#38237
Hello,
Beat LT music system display not working however cd/aux/fm all are working fine.

Any solution to this?

Thanks
8 months ago
·
#38645
All i know is, either the power to the top display unit is gone or it has gone bad! As someone has mentioned it earlier in the chat chain, probably there's a fuse! But I've last week gave my car for service with the same problem, but they told me that the entire module needs to be changed which costs around 30k which is not at all worth it. It looks to me like the power to the top module has disconnected in some way! I'm figuring out how to remove the unit so that i can investigate! When i succeed, i would sure let you know how to fix it over YouTube!
Thanks!
  • Page :
  • 1
There are no replies made for this post yet.
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below.
Supported: gif,jpg,png
· Insert · Remove
  Upload Files (Maximum 1MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.